No, at this time LTE-Kat. M is not supported.